Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

This article outlines the commands used to control the up.time agent on Solaris 10 and Solaris 11.

 

Table of Contents

Changing the agent port

  1. Open the file /etc/inet/services in a text editor.
  2. Find the following entry in the file:

    Code Block
    languagetext
    uptimeagent 9998/tcp # up.time agent
  3. Change the value of 9998/tcp to the port on which you want the agent to listen.

Change the agent user permissions

To change agent user permissions, enter the following command at the command line:

...

Where username is the name of the new agent user.

Start the agent service

To start the agent service, enter the following command at the command line:

Code Block
languagetext
svcadm enable network/uptimeagent/tcp

Stop the agent service

To stop the agent service, enter the following command at the command line:

Code Block
languagetext
svcadm disable network/uptimeagent/tcp

Confirm that the agent service is running

Code Block
languagetext
svcs -l network/uptimeagent/tcp

...

Code Block
languagetext
inetadm

Confirm that the inetd service is running properly

Enter the following command at the command line to verify that the inetd-dependent services are running:

Code Block
languagetext
svcs -l network/inetd

Confirm the status of security restrictions on the agent service

Confirm the status of any security restrictions on the agent service with the following commands:

Code Block
languagetext
# inetadm -l network/uptimeagent/tcp | grep wrappers
# svcprop -p defaults inetd | grep wrappers
# cat /etc/hosts.allow
# cat /etc/hosts.deny

Add the agent service manually

To manually add an agent, enter the following commands:

...

Where uptimeagent-tcp.xml is the file that contains the settings for the uptimeagent service.

Delete the agent service manually

The first command stops the agent service and the subsequent commands remove the agent service.

Code Block
languagetext
# svcadm disable network/uptimeagent/tcp
# svccfg delete network/uptimeagent/tcp
# rm ?f /var/svc/manifest/network/uptimeagent-tcp.xml

Refresh the agent settings

Use the following command to refresh the agent settings:

Code Block
languagetext
svcadm refresh network/uptimeagent/tcp

Set a service to start at boot

To set the agent service to start with the operating system, enter the following command:

...